Vertex |
An array that contains VertexIndex pairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The VertexIndexPairArray type exposes the following members.

Name | Description | |
---|---|---|
![]() | VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class |

Name | Description | |
---|---|---|
![]() | IsEmpty | Test to see if the array is empty. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | Item | Gets or sets a VertexIndex pair at a specified index within the array. |
![]() | Size | Returns the number of VertexIndex pairs that are in the array. |

Name | Description | |
---|---|---|
![]() | Append | |
![]() | Clear | Removes every VertexIndex pair from the array, rendering it empty. |
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | ForwardIterator | Retrieve a forward moving iterator to the array. |
![]() | GetEnumerator | Retrieve a forward moving iterator to the array. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Insert | |
![]() | ReverseIterator | Retrieve a backward moving iterator to the array. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |