VertexIndexPairArray Class


Vertex Index Pair Array Class

An array that contains VertexIndex pairs.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB VertexIndexPairArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexIndexPairArray : APIObject, 
	IEnumerable

The VertexIndexPairArray type exposes the following members.

Constructors
Name Description
Public method VertexIndexPairArray Initializes a new instance of the VertexIndexPairArray class
Top
Properties
Name Description
Public property IsEmpty Test to see if the array is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Item Gets or sets a VertexIndex pair at a specified index within the array.
Public property Size Returns the number of VertexIndex pairs that are in the array.
Top
Methods
Name Description
Public method Append
Public method Clear Removes every VertexIndex pair from the array, rendering it empty.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method ForwardIterator Retrieve a forward moving iterator to the array.
Public method GetEnumerator Retrieve a forward moving iterator to the array.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert
Public method ReverseIterator Retrieve a backward moving iterator to the array.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also