IFCExtrusion |
Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
TryCustom | 8 | A custom direction. |
TryDefault | 0 | The default value. |
TryX | 1 | The x-axis. |
TryXY | 3 | The x- and y-axes. |
TryXYZ | 7 | The x-, y-, and z-axes. |
TryXYZAndCustom | 15 | The x-, y-, and z-axes, and a custom direction. |
TryXZ | 5 | The x- and z-axes. |
TryY | 2 | The y-axis. |
TryYZ | 6 | The y- and z-axes. |
TryZ | 4 | The z-axis. |