DuctFittingAndAccessoryPressureDropItem Class


Duct Fitting And Accessory Pressure Drop Item Class

A flow path of the duct/pipe fitting and accessory. It is defined by the begin connector and end connector.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical DuctFittingAndAccessoryPressureDropItem

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctFittingAndAccessoryPressureDropItem : IDisposable

The DuctFittingAndAccessoryPressureDropItem type exposes the following members.

Properties
Name Description
Public property BeginConnectorIndex The index of the begin connector of the flow path.
Public property Coefficient The coefficient between the begin connector and end connector, Units: (kg/(ft·s²)).
Public property EndConnectorIndex The index of the end conector of the flow path.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property VelocityPressure The velocity pressure, for converting between coefficient and pressure drop on this flow path. Units: (kg/(ft·s²)).
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DuctFittingAndAccessoryPressureDropItem
Top
See Also