Duct
|
A flow path of the duct/pipe fitting and accessory. It is defined by the begin connector and end connector.

System
Object
Autodesk.Revit.DB.Mechanical DuctFittingAndAccessoryPressureDropItem
Autodesk.Revit.DB.Mechanical DuctFittingAndAccessoryPressureDropItem
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The DuctFittingAndAccessoryPressureDropItem type exposes the following members.

Name | Description | |
---|---|---|
![]() |
BeginConnectorIndex | The index of the begin connector of the flow path. |
![]() |
Coefficient | The coefficient between the begin connector and end connector, unitless. |
![]() |
EndConnectorIndex | The index of the end conector of the flow path. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
VelocityPressure | The velocity pressure, for converting between coefficient and pressure drop on this flow path. Units: (kg/(ft·s²)). |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the DuctFittingAndAccessoryPressureDropItem |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |