Item Property


Export Font Table Item Property

A copy of the ExportFontInfo for the font's ExportFontKey .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportFontInfo this[
	ExportFontKey fontKey
] { get; set; }

Parameters

fontKey ExportFontKey

Return Value

ExportFontInfo
A copy of the ExportFontInfo .
Exceptions
Exception Condition
ArgumentException When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.
See Also