DeleteEntity Method


Element Delete Entity Method

Deletes the existing entity created by %schema% in the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool DeleteEntity(
	Schema schema
)

Parameters

schema Schema
Schema used for creation of the entity

Return Value

Boolean
True if entity was deleted, false if entity didn't exist
Exceptions
Exception Condition
ArgumentException Writing of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException A non-optional argument was null
See Also