FolderItemInfo Class


Folder Item Info Class

Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FolderItemInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FolderItemInfo : IDisposable

The FolderItemInfo type exposes the following members.

Properties
Name Description
Public property ElementId The folder parameter Id
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The folder name
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FolderItemInfo
Top
Remarks
FolderItemInfo is the return value of BrowserOrganization.GetFolderItems().
See Also