Folder
|
Contains data for each folder item in the organization settings of the project browser including grouping parameter Id path and folder name.

System
Object
Autodesk.Revit.DB FolderItemInfo
Autodesk.Revit.DB FolderItemInfo
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The FolderItemInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() |
ElementId |
Obsolete.
The folder parameter Id |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
Name | The folder name |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the FolderItemInfo |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetGroupingParameterIdPath | The parameter Id path used to determine the folder items in the browser. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

FolderItemInfo is the return value of BrowserOrganization.GetFolderItems().