Analytical |
Represents the data and parameters of point load node.

System Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AnalyticalEquipmentLoadData type exposes the following members.

Name | Description | |
---|---|---|
![]() | ApparentLoad | The electrical apparent load of analytical equipment load. |
![]() | ConnectedPhases | The electrical connected phases of the electrical analytical node to its upstream node. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | Current | The current of the analytical equipment load. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | LoadClassification | The load classification of analytical equipment load. |
![]() | LoadSet | The electrical analytical load set of the analytical equipment load. |
![]() | LoadType | The load type of analytical equipment load. |
![]() | NumberOfPhases | Obsolete. The number of electrical phases. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | PhasesNumber | The number of electrical phases of the analytical equipment load. |
![]() | PowerFactor | The power factor of analytical equipment load. |
![]() | PowerFactorState | The PowerFactorState type of the analytical equipment load. |
![]() | TrueLoad | The electrical true load of analytical equipment load. |
![]() | Voltage | The voltage of the analytical equipment load. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |