AnalyticalEquipmentLoadData Class


Analytical Equipment Load Data Class

Represents the data and parameters of point load node.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class AnalyticalEquipmentLoadData : AnalyticalDistributionNodePropertyData

The AnalyticalEquipmentLoadData type exposes the following members.

Properties
Name Description
Public property ApparentLoad The electrical apparent load of analytical equipment load.
Public property ConnectedPhases The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property Current The current of the analytical equipment load.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property LoadClassification The load classification of analytical equipment load.
Public property LoadSet The electrical analytical load set of the analytical equipment load.
Public property LoadType The load type of analytical equipment load.
Public property PhasesNumber The number of electrical phases of the analytical equipment load.
Public property PowerFactor The power factor of analytical equipment load.
Public property PowerFactorState The PowerFactorState type of the analytical equipment load.
Public property TrueLoad The electrical true load of analytical equipment load.
Public property Voltage The voltage of the analytical equipment load.
Top
Methods
Name Description
Public method Dispose
(Inherited from AnalyticalDistributionNodePropertyData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also