AnalyticalEquipmentLoadData Class


Analytical Equipment Load Data Class

Represents the data and parameters of point load node.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class AnalyticalEquipmentLoadData : AnalyticalDistributionNodePropertyData

The AnalyticalEquipmentLoadData type exposes the following members.

Properties
Name Description
Public property ApparentLoad The electrical apparent load of analytical equipment load.
Public property Current The current of the analytical equipment load.
Public property LoadClassification The load classification of analytical equipment load.
Public property LoadSet The electrical analytical load set of the analytical equipment load.
Public property LoadType The load type of analytical equipment load.
Public property PhasesNumber The number of electrical phases of the analytical equipment load.
Public property PowerFactor The power factor of analytical equipment load.
Public property PowerFactorState The PowerFactorState type of the analytical equipment load.
Public property TrueLoad The electrical true load of analytical equipment load.
Public property Voltage The voltage of the analytical equipment load.
Top
Methods
Name Description
Top
See Also