Table |
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TableMergedCell type exposes the following members.

Name | Description | |
---|---|---|
![]() | TableMergedCell | Default constructor. |
![]() | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor. |

Name | Description | |
---|---|---|
![]() | Bottom | Specifies the row index of the bottom-right corner of a table grid. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Left | Specifies the column index of the top-left corner of a table grid. |
![]() | Right | Specifies the column index of the bottom-right corner of a table grid. |
![]() | Top | Specifies the row index of the top-left corner of a table grid. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TableMergedCell |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

A TableMergedCell contains member variables that define the top-left and bottom-right row and column indexes of a table grid. A TableMergedCell object can be passed as a function parameter wherever a TableMergedCell can be passed.