TableMergedCell Class


Table Merged Cell Class

The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TableMergedCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TableMergedCell : IDisposable

The TableMergedCell type exposes the following members.

Constructors
Name Description
Public method TableMergedCell Default constructor.
Public method TableMergedCell(Int32, Int32, Int32, Int32) Constructor.
Top
Properties
Name Description
Public property Bottom Specifies the row index of the bottom-right corner of a table grid.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Left Specifies the column index of the top-left corner of a table grid.
Public property Right Specifies the column index of the bottom-right corner of a table grid.
Public property Top Specifies the row index of the top-left corner of a table grid.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TableMergedCell
Top
Remarks
A TableMergedCell contains member variables that define the top-left and bottom-right row and column indexes of a table grid. A TableMergedCell object can be passed as a function parameter wherever a TableMergedCell can be passed.
See Also