Point |
Defines the measurement parameters necessary to create a point at a specific location on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointLocationOnCurve type exposes the following members.

Name | Description | |
---|---|---|
![]() | PointLocationOnCurve | Constructs a new instance of a class, with given or default values, to place a point on a curve. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MeasureFrom | The location on the curve from which the measurement is taken. |
![]() | MeasurementType | The measurement type. |
![]() | MeasurementValue | The measurement value. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the PointLocationOnCurve |

The class will store the following and provides functions to deal with them:
- The user visible Measurement Type (driving parameter type).
- The corresponding measurement value (driving parameter).
- MeasureFrom that tells from where the (driving parameter) measurement is calculated.