TypeBinding Class


Type Binding Class

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TypeBinding : ElementBinding

The TypeBinding type exposes the following members.

Constructors
Name Description
Public method TypeBinding Constructs an empty type binding.
Public method TypeBinding(CategorySet) Constructs a type binding with the set of categories passed.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.
See Also