TypeBinding Class


Type Binding Class

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TypeBinding : ElementBinding

The TypeBinding type exposes the following members.

Constructors
Name Description
Public method TypeBinding Constructs an empty type binding.
Public method TypeBinding(CategorySet) Constructs a type binding with the set of categories passed.
Top
Properties
Name Description
Public property Categories Retrieve or set the categories to which a parameter definition will be bound.
(Inherited from ElementBinding )
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.
See Also