Type |
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB TypeBinding
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB TypeBinding
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The TypeBinding type exposes the following members.

Name | Description | |
---|---|---|
![]() | TypeBinding | Constructs an empty type binding. |
![]() | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.