Type |
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB TypeBinding
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB TypeBinding
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The TypeBinding type exposes the following members.

Name | Description | |
---|---|---|
![]() | TypeBinding | Constructs an empty type binding. |
![]() | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed. |

Name | Description | |
---|---|---|
![]() | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding ) |
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.