Assembly |
Class that describes difference between two assembly members

System Object
Autodesk.Revit.DB AssemblyMemberDifference
Autodesk.Revit.DB AssemblyMemberDifferentCategory
Autodesk.Revit.DB AssemblyMemberDifferentGeometry
Autodesk.Revit.DB AssemblyMemberDifferentParameters
Autodesk.Revit.DB AssemblyMemberDifferentType
Autodesk.Revit.DB AssemblyMemberDifference
Autodesk.Revit.DB AssemblyMemberDifferentCategory
Autodesk.Revit.DB AssemblyMemberDifferentGeometry
Autodesk.Revit.DB AssemblyMemberDifferentParameters
Autodesk.Revit.DB AssemblyMemberDifferentType
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AssemblyMemberDifference type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AssemblyMemberDifference |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Different sub-classes of this class represent different kinds of differences between assembly members and contain additional data for each particular kind of difference.