Add Method


XYZ Add Method

Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ Add(
	XYZ source
)

Parameters

source XYZ
The vector to add to this vector.

Return Value

XYZ
The vector equal to the sum of the two vectors.
Exceptions
Exception Condition
ArgumentNullException Thrown when source is .
Remarks
The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.
See Also