XYZ Add Method |
Adds the specified vector to this vector and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- source XYZ
- The vector to add to this vector.
Return Value
XYZThe vector equal to the sum of the two vectors.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when source is . |

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.