BRep |
This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BRepBuilderGeometryId type exposes the following members.

Name | Description | |
---|---|---|
![]() | BRepBuilderGeometryId | Copy constructor |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BRepBuilderGeometryId |
![]() ![]() | InvalidGeometryId | Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error. |

The user should use these ids to organize the calls to BRepBuilder methods (e.g., addLoop() takes a face id as input, referring to a face that was previously added by a call to AddFace()). The ids are only valid while the BRepBuilder is in use.