BRepBuilderGeometryId Class


BRep Builder Geometry Id Class

This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BRepBuilderGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BRepBuilderGeometryId : IDisposable

The BRepBuilderGeometryId type exposes the following members.

Constructors
Name Description
Public method BRepBuilderGeometryId Copy constructor
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BRepBuilderGeometryId
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member InvalidGeometryId Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The user should use these ids to organize the calls to BRepBuilder methods (e.g., addLoop() takes a face id as input, referring to a face that was previously added by a call to AddFace()). The ids are only valid while the BRepBuilder is in use.
See Also