IFCImportOptions Class


IFCImport Options Class

IFC Import options.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCImportOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class IFCImportOptions : IDisposable

The IFCImportOptions type exposes the following members.

Constructors
Name Description
Public method IFCImportOptions Constructs a new IFCImportOptions using default settings.
Top
Properties
Name Description
Public property Action The action of the import.
Public property AutocorrectOffAxisLines Enable or disable correcting lines that are slight off-axis.
Public property AutoJoin Enable or disable auto-join at the end of import.
Public property CreateLinkInstanceOnly Determines whether to create a linked symbol element or not.
Public property ForceImport Force the IFC file to be imported regardless of an existing corresponding Revit file.
Public property Intent The intent of the import.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property RevitLinkFileName The full path of the intermediate Revit file created during a previous link action. This is used during "Reload From" to determine the path to the previous generated Revit file.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCImportOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetConversionData Get the data used in the creation of the associated Revit file for an IFC link operation, if it exists.
Public method GetExtraOptions Get the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetExtraOptions
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also