IFCImport
|
IFC Import options.

System
Object
Autodesk.Revit.DB.IFC IFCImportOptions
Autodesk.Revit.DB.IFC IFCImportOptions
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The IFCImportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IFCImportOptions | Constructs a new IFCImportOptions using default settings. |

Name | Description | |
---|---|---|
![]() |
Action | The action of the import. |
![]() |
AutocorrectOffAxisLines | Enable or disable correcting lines that are slight off-axis. |
![]() |
AutoJoin | Enable or disable auto-join at the end of import. |
![]() |
CreateLinkInstanceOnly | Determines whether to create a linked symbol element or not. |
![]() |
ForceImport | Force the IFC file to be imported regardless of an existing corresponding Revit file. |
![]() |
Intent | The intent of the import. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
LinkOrientation | The orientation of the Linked IFC File in the Host Document. |
![]() |
LinkPosition | The position of the Linked IFC File in the Host Document. |
![]() |
RevitLinkFileName | The full path of the intermediate Revit file created during a previous link action. This is used during "Reload From" to determine the path to the previous generated Revit file. |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the IFCImportOptions |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetConversionData | Get the data used in the creation of the associated Revit file for an IFC link operation, if it exists. |
![]() |
GetExtraOptions | Get the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
SetExtraOptions | |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |