BeforeExecutedEventArgs Class


Before Executed Event Args Class

The event arguments used by AddInCommandBinding's BeforeExecuted event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BeforeExecutedEventArgs : CommandEventArgs

The BeforeExecutedEventArgs type exposes the following members.

Properties
Name Description
Public property UsingCommandData Indicates whether or not the Revit journal will include custom data populated by the application associated with this command.
Top
Methods
Name Description
Top
Remarks
This event is cancellable. If your callback sets the Cancel property to true, the command will not execute.
See Also