BeforeExecutedEventArgs Class


Before Executed Event Args Class

The event arguments used by AddInCommandBinding's BeforeExecuted event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BeforeExecutedEventArgs : CommandEventArgs

The BeforeExecutedEventArgs type exposes the following members.

Properties
Name Description
Public property ActiveDocument The active document.
(Inherited from CommandEventArgs )
Public property Cancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs )
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs )
Public property CommandId The command id.
(Inherited from CommandEventArgs )
Public property UsingCommandData Indicates whether or not the Revit journal will include custom data populated by the application associated with this command.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This event is cancellable. If your callback sets the Cancel property to true, the command will not execute.
See Also