Before |
The event arguments used by AddInCommandBinding's BeforeExecuted event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events BeforeExecutedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events BeforeExecutedEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The BeforeExecutedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | UsingCommandData | Indicates whether or not the Revit journal will include custom data populated by the application associated with this command. |

Name | Description | |
---|---|---|

This event is cancellable. If your callback sets the Cancel property to true, the command will not execute.