GetHookPlaneNormalForBarIdx Method


Rebar Update Curves Data Get Hook Plane Normal For Bar Idx Method

Returns the normal of plane in which the hook at end of bar with index barPositionIndex that is currently in Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (GetNumberOfBars()-1).

Return Value

XYZ
The normal of plane in which the hook at end of bar with index barPositionIndex that is currently in Rebar.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, GetNumberOfBars()-1 ]. -or- Invalid end.
See Also