GetHookPlaneNormalForBarIdx Method


Rebar Update Curves Data Get Hook Plane Normal For Bar Idx Method

Note: This API is now obsolete.

Returns the plane's normal in which the termination at end of bar with index barPositionIndex that is currently in Rebar. The normal is used for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarUpdateCurvesData.GetTerminationPlaneNormalForBarIdx instead.")]
public XYZ GetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (GetNumberOfBars()-1).

Return Value

XYZ
The plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex that is currently in Rebar. The normal is used for both hook and crank.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, GetNumberOfBars()-1 ]. -or- Invalid end.
See Also