GeometryElement Class


Geometry Element Class

Geometric representation of an element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GeometryElement : GeometryObject, 
	IEnumerable<GeometryObject>

The GeometryElement type exposes the following members.

Properties
Name Description
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property MaterialElement Element describing the material from which this element is composed.
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method GetBoundingBox Retrieves a box that encloses the geometry element.
Public method GetEnumerator Returns an enumerator that iterates through the collection.
Protected method GetEnumeratorNG Returns an enumerator that iterates through the collection.
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetTransformed Returns a transformed copy of the geometry in this element.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.
See Also