Geometry |
Geometric representation of an element.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryElement
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryElement
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The GeometryElement type exposes the following members.

Name | Description | |
---|---|---|
![]() | MaterialElement | Element describing the material from which this element is composed. |

Name | Description | |
---|---|---|
![]() | GetBoundingBox | Retrieves a box that encloses the geometry element. |
![]() | GetEnumerator | Returns an enumerator that iterates through the collection. |
![]() | GetEnumeratorNG | Returns an enumerator that iterates through the collection. |
![]() | GetTransformed | Returns a transformed copy of the geometry in this element. |

This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.