Geometry |
Geometric representation of an element.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryElement
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB GeometryElement
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The GeometryElement type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject ) |
![]() | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject ) |
![]() | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject ) |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | MaterialElement | Element describing the material from which this element is composed. |
![]() | Visibility | The visibility. (Inherited from GeometryObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Inherited from GeometryObject ) |
![]() | GetBoundingBox | Retrieves a box that encloses the geometry element. |
![]() | GetEnumerator | Returns an enumerator that iterates through the collection. |
![]() | GetEnumeratorNG | Returns an enumerator that iterates through the collection. |
![]() | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject ) |
![]() | GetTransformed | Returns a transformed copy of the geometry in this element. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.