Progress |
The event arguments used by the ProgressChanged event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events ProgressChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events ProgressChangedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ProgressChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Caption | The text from the progress bar caption that describes the operation in progress |
![]() | LowerRange | Lower part of progress bar range - always zero |
![]() | Position | Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged" |
![]() | Stage | The current stage of the progress bar |
![]() | UpperRange | Upper part of progress bar range - will be any non-zero number |

Name | Description | |
---|---|---|
![]() | Cancel | Requests to cancel the progress bar's operation. |