ProgressChangedEventArgs Class


Progress Changed Event Args Class

The event arguments used by the ProgressChanged event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProgressChangedEventArgs : RevitAPISingleEventArgs

The ProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property Caption The text from the progress bar caption that describes the operation in progress
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Public property LowerRange Lower part of progress bar range - always zero
Public property Position Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property Stage The current stage of the progress bar
Public property UpperRange Upper part of progress bar range - will be any non-zero number
Top
Methods
Name Description
Public method Cancel Requests to cancel the progress bar's operation.
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also