ProgressChangedEventArgs Class


Progress Changed Event Args Class

The event arguments used by the ProgressChanged event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProgressChangedEventArgs : RevitAPISingleEventArgs

The ProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Caption The text from the progress bar caption that describes the operation in progress
Public property LowerRange Lower part of progress bar range - always zero
Public property Position Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property Stage The current stage of the progress bar
Public property UpperRange Upper part of progress bar range - will be any non-zero number
Top
Methods
Name Description
Public method Cancel Requests to cancel the progress bar's operation.
Top
See Also