Curve |
Tests whether this curve element has any locked tangent joins at the given end-point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- end Int32
- Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
Return Value
BooleanReturns True if the curve element is tangentially locked to at least one other curve element at the given end-point; returns False otherwise.

Note that tangent locks between two elements at their joined ends are always kept in sync with each other. It means that if one curve element is locked to another curve, the other curve will be automatically locked to the first curve at the shared join.