Analytical |
Returns the curve of the Analytical Element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
InapplicableDataException | This AnalyticalElement contains more than one single curve. |

If the Analytical Element cannot be expressed as a single curve, an exception is thrown.

C#
public void GetColumnCurve(AnalyticalElement member)
{
// get AnalyticalElement from structural column
if (member.StructuralRole == AnalyticalStructuralRole.StructuralRoleColumn)
{
// column should be represented by a single curve
if (member.IsSingleCurve() == true)
{
Curve columnCurve = member.GetCurve();
}
}
}