GetCurve Method


Analytical Element Get Curve Method

Returns the curve of the Analytical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Curve GetCurve()

Return Value

Curve
The curve of the Analytical Element.
Exceptions
Exception Condition
InapplicableDataException This AnalyticalElement contains more than one single curve.
Remarks
If the Analytical Element cannot be expressed as a single curve, an exception is thrown.
See Also