Spec |
A utility class of functions related to specs. A spec describes a data type that parameters can hold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SpecUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | GetAllSpecs | Gets the identifiers of all specs. |
![]() ![]() | IsSpec | Checks whether a ForgeTypeId identifies a spec. |
![]() ![]() | IsValidDataType | Returns true if the given ForgeTypeId identifies a valid parameter data type. |