SpecUtils Class


Spec Utils Class

A utility class of functions related to specs. A spec describes a data type that parameters can hold.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SpecUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SpecUtils

The SpecUtils type exposes the following members.

Methods
Name Description
Public method Static member GetAllSpecs Gets the identifiers of all specs.
Public method Static member IsSpec Checks whether a ForgeTypeId identifies a spec.
Public method Static member IsValidDataType Returns true if the given ForgeTypeId identifies a valid parameter data type.
Top
See Also