GetConditionAt Method


Routing Conditions Get Condition At Method

Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RoutingCondition GetConditionAt(
	int index
)

Parameters

index Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

RoutingCondition
The found routing condition.
Exceptions
Exception Condition
ArgumentOutOfRangeException index is not within the valid range of available conditions.
See Also