Routing |
Gets the routing condition at the specified index position.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- index Int32
- The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.
Return Value
RoutingConditionThe found routing condition.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | index is not within the valid range of available conditions. |