FindMergeableClusters Method


Part Utils Find Mergeable Clusters Method

Segregates a set of elements into subsets which are valid for merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ICollection<ElementId>> FindMergeableClusters(
	Document doc,
	ICollection<ElementId> partIds
)

Parameters

doc Document
The document.
partIds ICollection ElementId
A set of element ids.

Return Value

IList ICollection ElementId
An array of clusters such that all the elements in a single cluster are valid for merge. Each cluster will be maximal in that appending any of the other Parts specified as input will result in a collection that is not valid for merge.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Element ids in the input set that do not correspond to Part elements will be ignored, as will element ids corresponding to Part elements that already have associated parts.
See Also