Dimension Text |
The position of the dimension text's drag point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | Thrown when:
|

This property is not applicable to all dimensions. For example, it is not available for spot slope dimensions, multi-segments dimensions, dimensions using equality formula, and when dimension style is ordinate.
If the position is not applicable, this property throws InvalidOperationException.

C#
// Get the current text XYZ position
XYZ currentTextPosition = dimToModify.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0.0, 1.0, 0.0)).OfPoint(currentTextPosition);
// Set the new text position
dimToModify.TextPosition = newTextPosition;