TextPosition Property


Dimension Text Position Property

The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ TextPosition { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- Thrown when:
  • SpotDimension has more than one segments.
-or-
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot slope dimensions, multi-segments dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property throws InvalidOperationException.

See Also