GetDefaultHookOrientation Method


Rebar Shape Get Default Hook Orientation Method

Get the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarHookOrientation GetDefaultHookOrientation(
	int index
)

Parameters

index Int32
0 for the starting hook, 1 for the ending hook.

Return Value

RebarHookOrientation
Exceptions
Exception Condition
ArgumentOutOfRangeException index must be 0 or 1.
Remarks
Replaces the method GetHookOrientation() from prior releases.
See Also