GetDefaultHookOrientation Method


Rebar Shape Get Default Hook Orientation Method

Note: This API is now obsolete.

Gets the termination's orientation. The orientation it's the same for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.GetTerminationsData().TerminationOrientationAtStart or RebarShape.GetTerminationsData().TerminationOrientationAtEnd instead.")]
public RebarHookOrientation GetDefaultHookOrientation(
	int end
)

Parameters

end Int32
0 for the termination at start, 1 for the termination at end.

Return Value

RebarHookOrientation
Returns the termination's orientation. The orientation it's the same for both hook and crank.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
See Also