Analysis |
Contains deformed shape settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisDisplayDeformedShapeSettings | Constructs a default instance of deformed shape settings. |
![]() | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object. |

Name | Description | |
---|---|---|
![]() | GridColor | Color of grid lines. |
![]() | GridLineWeight | Line weight of grid lines. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape. |
![]() | ShowContourLines | If true, show contour lines in the analysis display. |
![]() | ShowGridLines | If true, show grid lines in the analysis display. |
![]() | TextLabelType | Type of deformed shape text visualization. |
![]() | TextTypeId | Element id of text associated with the settings. |
![]() | Transparency | Transparency percentage of deformed shape color fill on surfaces |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AnalysisDisplayDeformedShapeSettings |
![]() | IsEqual | Compares two deformed shape settings objects. |