AnalysisDisplayDeformedShapeSettings Class


Analysis Display Deformed Shape Settings Class

Contains deformed shape settings for analysis display style element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayDeformedShapeSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayDeformedShapeSettings : IDisposable

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayDeformedShapeSettings Constructs a default instance of deformed shape settings.
Public method AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object.
Top
Properties
Name Description
Public property GridColor Color of grid lines.
Public property GridLineWeight Line weight of grid lines.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Rounding Increment to which numeric values of analysis results are rounded in deformed shape.
Public property ShowContourLines If true, show contour lines in the analysis display.
Public property ShowGridLines If true, show grid lines in the analysis display.
Public property TextLabelType Type of deformed shape text visualization.
Public property TextTypeId Element id of text associated with the settings.
Public property Transparency Transparency percentage of deformed shape color fill on surfaces
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalysisDisplayDeformedShapeSettings
Public method IsEqual Compares two deformed shape settings objects.
Top
See Also