Angular |
Creates a new instance of an Angular Dimension element within the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AngularDimension Create(
Document document,
View dbView,
Arc arc,
IList<Reference> references,
DimensionType dimensionStyle
)
Parameters
- document Document
- The document where new Angular Dimension is created.
- dbView View
- The view in which the Angular Dimension will appear.
- arc Arc
- Arc for the Angular Dimension.
- references IList Reference
- The references which the Angular Dimension will witness.
- dimensionStyle DimensionType
- Dimension Style.
Return Value
AngularDimensionThe newly created Angular Dimension instance, or if the operation fails.

Exception | Condition |
---|---|
ArgumentException | References should be: at least two, non parallel and rays of the arc passed. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |