Failure |
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureDefinitionRegistry type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FailureDefinitionRegistry |
![]() | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId. |
![]() | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions. |

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry