Failure |
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureDefinitionRegistry type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FailureDefinitionRegistry |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry