FailureDefinitionRegistry Class


Failure Definition Registry Class

The global registry for all FailureDefinitions in the Revit session.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FailureDefinitionRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailureDefinitionRegistry : IDisposable

The FailureDefinitionRegistry type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FailureDefinitionRegistry
Public method FindFailureDefinition Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method ListAllFailureDefinitions Retrieves all the registered FailureDefinitions.
Top
Remarks
When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry
See Also