Create Method (Document, IList(Curve), SketchPlane, Int32)


Beam System Create(Document, IList Curve , Sketch Plane, Int 32) Method

Creates a 2D BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	SketchPlane sketchPlane,
	int curveIndexForDirection
)

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
sketchPlane SketchPlane
The work-plane for the BeamSystem.
curveIndexForDirection Int32
Index of the curve in the profile to be used as direction. '0' means the default direction-to use the first curve in profile. The curve from the profile to be used as direction must be a Line.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception Condition
ArgumentException SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane. -or- The curve index must be valid and the curve to be used as direction must be a Line.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also