Topography |
Identifies whether the facets can construct a valid topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- facets IList PolymeshFacet
- The facets to be checked.
- points IList XYZ
- A collection of points.
Return Value
BooleanTrue if the facets are valid, otherwise false.

Exception | Condition |
---|---|
ArgumentException | There are no points in the input points set. -or- There were not enough points to form a valid region (at least 3 are required), or the points were collinear ignoring elevation. |
ArgumentNullException | A non-optional argument was null |